Minimum Outlook Version Support as of November 1st

October 13, 2021

Microsoft announced new minimum requirements for using Outlook on Windows with Microsoft 365.  Only Outlook 2013 Service Pack 1 (with the latest fixes) and later will be able to connect to Microsoft 365 services as of November 1st, 2021.

Note that Microsoft 365 is the platform used for CUIMC email accounts; if you are not using a compatible version of Outlook, it will no longer connect to your CUIMC email beginning November 1st.

To check your version please see Microsoft's What version of Outlook do I have?. If you need to update Outlook to a newer version, please contact your Certified IT Group or CUIMC's licensed Microsoft 365 Apps page for help downloading and installing a current version.